Infrastructure Issues Impacting Pay by Bank
Incident Report for Link Financial
Resolved
AWS has restored all services and is processing any residual backlogs. We are fully operational and our monitoring has observed no service interruptions issues since resolution.
Posted Jun 13, 2023 - 17:39 EDT
Monitoring
AWS is beginning to see improvements and continues to work towards a full recovery
Posted Jun 13, 2023 - 17:02 EDT
Identified
AWS has identified the root cause and are actively working to resolve the issue.
Posted Jun 13, 2023 - 15:46 EDT
Investigating
We understand that AWS is experiencing a service interruption that is impacting our Pay by Bank product. We will provide more updates as we have them.

If you have any questions or would like to contact us please email: support@link.money.
Posted Jun 13, 2023 - 15:34 EDT
This incident affected: Linking Flow.