Latency Issues Impacting Pay by Bank
Incident Report for Link Financial
Resolved
We are fully operational and our monitoring has observed no latencies issues since resolution.

If you continue to experience issues, please contact us at support@link.money.
Posted Mar 28, 2023 - 17:48 EDT
Monitoring
The issue is now resolved and we are monitoring closely.
Posted Mar 28, 2023 - 16:55 EDT
Identified
We've identified an issue with one of our downstream providers and the issue is being resolved. We are continuing to monitor the situation and will provide another update when we have verified that the latency issues have been fully resolved.
Posted Mar 28, 2023 - 16:23 EDT
Investigating
We are investigating issues resulting in latency that is impacting our Pay by Bank product. Our engineers are working on this issue as a top priority. We will provide more updates as we have them. If you have any questions or would like to contact us please email: support@link.money.
Posted Mar 28, 2023 - 13:33 EDT
This incident affected: Linking Flow.