US Bank unavailable
Incident Report for Link Financial
Resolved
This incident has been resolved.
Posted May 31, 2023 - 21:06 EDT
Investigating
We are investigating issues related to US Bank being unavailable. We will provide more updates as we have them. If you have any questions or would like to contact us please email: support@link.money.
Posted May 31, 2023 - 18:55 EDT
This incident affected: Bank Status (Production).